Gutsy auf Lenovo 3000 N200

Notebook IconIch habe mir einen Lenovo 3000 N200 gekauft und gestern kam es an. Vorinstalliert war ein Windows Vista Buisses, welches ich kurz bootete, während ich mir die Tribe5 von Gutsy Gibbon saugte. Jetzt weiß ich auch warum es so viele “Vorurteile” gegen Vista gibt… Ich hätte nicht gedacht, dass es wirklich so schlecht ist. Ist aber vielleicht auch ein Stück weit Geschmackssache. Als mein Ubuntu Gutsy Tribe5 einige Minuten später dann auf CD gebrannt war, konnte ich endlich mit der Installation des Betriebssystem meines Vertrauens – Ubuntu – beginnen.


Eckdaten des Notebooks:
Prozessor: Core2Duo T73002x2.0Ghz (Santa Rosa)
Ram: 2GB DDR2 (max: 4GB)
HDD: 160GB S-ATA
Laufwerk: DVD Dual-Layer Multi Brenner
Grafikkarte: 256MB NVidia GeForce Go 7300
Display: 15,4″ Widescreen (1680×1050)
Special: integrierte Webcam, Fingerprint Reader, 5 in 1 Kartenleser

Zur Installation:

Die Grundinstallation des (noch nicht stabielen!) Ubuntu 7.10 verlief problemlos: Ein Paar Daten angegeben, 20min gewartet und das System lief. Als ich dann zum ersten mal mein Ubuntu bootete bot mir die Verwaltung eingeschränkter Treiber auch gleich die Installation für den Nvidia-3D-Treiber an und ich installierte ihn (auch wenn er Closed-Source ist, ich hoffe Nouveau ist bald eine brauchbare Alternative). Nach einem Restart von X lief dann auch gleich – ohne irgendwelche Einstellungen zu tätigen – Compiz Fusion. Auch der Wlan lief direk von Anfang an ohne Probleme mit dem Intel PRO/Wireless 4965AGN Chipsatz. Somit lies sich eine kabellose Internetverbindung (WPA2 verschlüsselt) ohne Probleme mit dem NetworkManager aufbauen. Außerdem funktionierte die Tastatur inkl. Sondertasten und Fn-Kombinationen out-of-the-box.
Ein Problem gab es jedoch mit dem Sound (Intel HDA 82801H ICH8 Familie). Dieser Chipsatz wurde zwar erkannt, jedoch blieben die Lautsprecher stumm. Doch auf dieses Problem fand ich im Ubuntuusers.de Forum und Wiki eine Lösung:
Ich habe in der Datei /etc/modprobe.d/alsa-base als root
options snd-hda-intel model=lenovo
als letzte Zeile hinzugefügt (Wiki). Somit war dieses Problem gelöst.

offene Probleme:

[Gelöst] Ich habe keinen Treiber für die Webcam.
[Gelöst] Ich habe keinen Treiber für den Fingerprint-Reader.
[Gelöst] Der Kartenleser funktioniert nicht (ist wohl auch ein Treiberproblem).

Da diese Probleme eher klein und nebensächlich sind, bin ich alles in allem sehr mit dem Notebook zufrieden, da es auch eine sehr gute Quallität und Verarbeitung hat.

Und ich denke diese Problemchen werden sich noch lösen lassen. Wenn alles gleich funktionieren würde, wäre es ja langweilig =P.

Falls sich jemand auskennt: Lohnt es sich eine 64Bit-Version auf dem C2D T7300 mit 2GB Ram zu benutzen?

weiterführende Links:
Weitere Installationsanleitungen zum Lenovo 3000 N200 und anderen Laptops, auch mit neueren Versionen findet man unter: Tuxmobil.de.

72 thoughts on “Gutsy auf Lenovo 3000 N200

  1. fenix

    hi slyon,

    versuche grad meine auflösung von 1280×800 auf 1440×900 zu verändern aber ich hab immer wieder die alte auflösung trotz neustart
    X.Org X Server 1.4.0.90
    GDM 2.20.6
    NVIDIA Driver 169.12

    hier ein auszug aus meiner xorg.conf:

    Section “Monitor”
    Identifier “Standardbildschirm”
    Option “DPMS”
    Horizsync 28-64
    Vertrefresh 43-60
    Modeline “1440x900_60.00″ 106.47 1440 1520 1672 1904 900 901 904 932 -HSync +Vsync
    EndSection

    Section “Screen”
    Identifier “Default Screen”
    Device “nVidia Corporation G72M [Quadro NVS 110M/GeForce Go 7300]”
    Monitor “Standardbildschirm”
    Defaultdepth 24
    SubSection “Display”
    Modes “1440×900″
    EndSubSection
    EndSection

    würd mich sehr freuen, wenn du mir mal erklärst, wie ich die auflösung vergrössern kann

    dank im voraus

  2. slyon

    hi fenix!

    Im Normalfall sollte sich die maximale Auflösung bei Nvidia Binary Treiber automatisch einstellen.Ansonsten kann man größere Auflösungen in die xorg.conf eintragen, so wie du es schon getan hast.

    Da sich bei dir jedoch trotzdem nichts tut, vermute ich, dass du ein Modell hast, dessen Display einfach nicht mehr als 1280×800 schafft.

    Ich wüsste nicht was du noch machen kannst. Vielleicht gibt es ja noch irgend einen Trick um die Auflösung zu erhöhen… Wühle dich am besten mal durch Foren, die sich mit diesem Thema beschäftigen.

    Slyon

  3. fenix

    hi slyon,

    klasse, das du geantwortest hast ^^
    als ich die eckdaten oben auf der seite gelesen hab, dachte ich, du hast die auflösung hinbekommen, hehe
    das geht auf jeden fall mit dem notebook, aber unter linux glaub ich derzeit nicht .. vielleicht ja in dem nächsten release

    fenix

  4. slyon

    hey fenix,

    ich habe auf meinem Notebook eine Auflösung von 1680×1050 aber es kann sein, dass du ein etwas kleineres Model mit schlechterem Display hast.

    Slyon

  5. fenix

    hi slyon,

    stimmt, hab grad mal den product key auf der lenovo seite eingegeben.
    mein (erstes) notebook kann wirklich nur 1280×800
    da weiss ich auf jeden fall, wo ich beim nächsten mal noch drauf achten werde ^^

    fenix

  6. Timbo

    Hmm.. also den Card-Reader bekomme ich einfach nicht zum Laufen. Der erkennt einfach keine xD-Karten (mit anderen kann ich es leider nicht ausprobieren). :(

  7. slyon

    Hi Timbo,

    bei mir kann er leider auch keine XD-Karten lesen, dafür klappt es mit SD-Karten out-of-the-box.

    Slyon

  8. Timbo

    Oh, ok. Naja, leider funzt mein externer Kartenleser auch nicht mit ubuntu. Muss ich mir wohl eine andere Lösung einfallen lassen. Aber Danke für diesen Eintrag hier. Hat mir sehr geholfen.

  9. fenix

    hi,

    hab grad was zur wlan led gefunden für hardy ^^

    :~$ sudo apt-get install linux-backports-modules-hardy

    und

    :~$ sudo rmmod iwl3945; sudo modprobe iwl3945

    gruß fenix

  10. Slyon

    Danke für den Tipp fenix!

    Unter Archlinux funktioniert die LED durch die Installation von compat-wireless bzw. druch ein Update auf Kernel 2.6.26

    Slyon

  11. minimaus

    mein internet funktioniert nicht mehr
    wegen meinem netzwerk unten in einer leiste steht immer netzwerk nicht verbunden und das ist doof weil ich dann nicht mehr ins internet kann das nervt mich weil ich sehr viele referate halten muss und daten aus dem internet brauche aber das geht ja nicht bitte gebt mir antwort minimaus

  12. slyon

    minimaus,
    hast du dein Wlan Netzwerk schon zum verbinden angeklickt, bzw dein Kabel eingesteckt?

    Falls ja, wende dich am besten mit einer Fehlermeldung ans – forum.ubuntuusers.de – Forum. Dort hast du mehr Zulauf.

    slyon

Comments are closed.